
CHAPTER 6: The Edit Menu
The Edit menu contains commands that allow you to cut, copy, paste, clear, 
and fill a document or a portion of a document. There are also commands for
publishing and setting various preferences.

Undo
The Undo command [Command-Z] allows you to reverse the actions you 
perform in a document. The menu display shows the last action taken that 
can be undone (such as Undo Selection). If the change can’t be reversed, the
Edit menu displays Can’t Undo.
Color It! provides multiple levels of Undo—you can undo up to 16 of the last 
operations performed in a document, in reverse order. The 
number of undos are set in the General Preferences dialog box. When you 
switch to a different document, Color It! keeps only the most recent undo for 
the inactive documents.

Redo
The Redo command [Command-R] lets you restore an action you reversed 
with the Undo command.
Like the Undo command, Color It! provides up to 16 levels of Redo. When you
switch to a different document, Color It! keeps only the most recent Redo for 
the inactive documents.

Cut
The Cut command [Command-X] removes the active selection from the 
document (leaving a hole filled with the background color) and places it on 
the Clipboard.

Copy
The Copy command [Command-C] copies the active selection and places a 
duplicate of it on the Clipboard.

Paste
The Paste command [Command-V] places a copy of the Clipboard contents 
into a document while keeping a copy of the image on the Clipboard.

Clear
The Clear command functions much like the Cut command: it removes the 
active selection from the document (leaving a hole filled with the background
color) but does not copy to the Clipboard.

Paste Into
The Paste Into command puts the contents of the Clipboard into a selection, 
keeping its original proportions. The marquee lines show the shape of the 



pasted image, and it can be moved to position the portion wanted to show 
through the selection.

Paste Behind
The Paste Behind command puts the contents of the Clipboard behind a 
selection rather than into it. The original image shows in the selection. The 
pasted image can be moved to reposition it behind the selection.

Paste To Fit
The Paste To Fit command changes the proportions of the contents of the 
Clipboard so that the pasted image completely fills the selection.

Fill
The Fill command fills a selection with the foreground color.
Frame…
The Frame… command opens a dialog box that lets you set the width of a 
frame for a selection in pixels. Clicking the Frame button put a frame of the 
specified width using the Frame color within the selection.

Publishing
If you are working with System 7.0 or above, Color It! adds publishing options
to the Edit menu.
The ability to publish images is a very powerful feature. Any document or 
selection can be published and then be subscribed to by other documents. 
Once this link is made, any changes in the original image will automatically 
be updated in any subscribing documents. 

Create Publisher… This command allows you to publish any part of a 
document. This command opens a dialog box where the location and name 
for the new publisher 
document is specified. Once a publisher is created, it can be subscribed to in 
other Macintosh programs that support publish and subscribe.
To create a publisher, first select an area of the document with any selection 
tools. If there is no active selection, the entire document will be published. 
Next select Create Publisher… and choose a location and a file name. To 
publish the image, select the Publish button.
Publisher Options… By default, whenever a document that contains 
publishers is saved, changes to areas that have been 
published will be automatically saved to the publisher files.
You can choose to override this option by clicking on the Manually radio 
button. While this setting is in effect, the publisher will only be updated when
you click the Send Edition Now button in the Publisher Options dialog box. To 
update publishers each time a document is saved, click the On Save radio 
button.
The Publisher Options dialog box also allows you to cancel a publisher. 
Clicking the Cancel Publisher button will remove the publisher from the 



document. By clicking on the pop-up at the top of the dialog, you can see the
path to the current publisher.
Show Borders/Hide Borders is a toggle command that displays or hides grey 
borders around each published regions in a document. To select a publisher, 
click on its border with the Pointer tool. This converts the published region 
into an active selection. Whenever the file is saved, any changes made to 
the contents of this selection will automatically be updated in any document 
which subscribes to this region.

Preferences
The Preferences hierarchical menu lets you set preferences defaults for many
areas of Color It! These include General, Display, Files, Tools, Rulers, and 
Separation.
General Preferences [Command-K]
The Startup area controls what Color It! displays when first started. The 
Startup With pop-up lets you select Untitled Document, New Dialog, Open 
Dialog, or 
Nothing. The Define Document… button (active only when Untitled 
Document is chosen) opens the New Image dialog box, where options are set
for the document appearing at startup. The options are described in Chapter 
5, The File Menu.
The Clipboard area controls images copied to the clipboard. Checking the 
Export to other applications checkbox stores the image in a form useable by 
other programs. The Mode 
pop-up menu lets you select Normal, Dither, or Transparent modes. 
Transparent converts pure white areas of the image to clear areas.
The Color Optimization area optimizes images displayed on monitors with 
fewer colors than in the image—say, viewing a millions of colors document 
on a 256 color screen. 
Enter the percent of colors in the image to be optimized in the Amount 
checkbox. It is generally best to leave this at the default setting of 75% to 
allow for 
new colors introduced through paint or paste operations.
Check either the After opening or Before saving checkboxes to determine 
when optimization occurs. Checking After opening ensures images from 
other programs have the same image quality as those created in Color It!
The Undo area lets you enter the number of Undo operations available in 
Color It! from 1 to 16.
The After Long Operations area lets you select notification methods when the
operations complete. The menubar flashes when the Flash Menubar box is 
checked. You can also select a sounds alert from the Mode pop-up menu. The
sounds shown are those available through your System.

Display Preferences
The Open Images area lets you select how images are displayed.
The Where pop-up menu lets you choose a monitor in multiple-monitor 



systems. On Best Screen opens the window on the screen with the highest 
resolution when multiple screens are used.
On Alternate Screens 
keeps the same number of windows on each screen when multiple screens 
are used.
On Main Screen opens all windows on the screen containing the menu bar 
(the main monitor).
Checking the Display at Resolution checkbox opens documents at the same 
dimensions they were saved in. Left unchecked, documents are displayed at 
72dpi—thus a 300 dpi document appears roughly four times its size.
Checking the Fit in Window checkbox always sizes documents so the entire 
document fits within the window.
The Document Border area controls the borders surrounding the document 
image in the main window. None displays without a border; Thin displays a 4 
pixel wide border; 
Thick displays a wider border around the image. The Color pop-up menu lets 
you select a border of gray, black, white, or other color (which opens the 
standard Apple color wheel to choose a color).
Checking the Dither on monitors without enough colors checkbox dithers 
images if your monitor does not support as many colors as the document 
contains.
Checking the Display color channels in color shows the individual channels in
the appropriate colors (Yellow for the yellow channel of a CMYK image, for 
example).
Checking the Show image info in header of windows displays the file size, 
measurements (in units set in the
Ruler Preferences dialog box) and the file type.
Check Display values in percentage if you wish to do so.
Files… Preferences
The File Preferences area controls many aspects of the document.
The Format pop-up menu is used to select the specific file format in which to 
save the document. Options include TIFF, Macintosh PICT, PostScript®, Paint,
Photoshop™ 2.0 and Photoshop™ 2.5, StartupScreen, Photone™ Prepress 
and QuickTime™ PICT.
The Options button opens a dialog box allowing you to set format-specific 
preferences. The options for each format are discussed under Save As… in 
Chapter 5, The File Menu.
Checking the Prompt for Options each Save As checkbox opens the Options 
dialog each time a Save As is performed.
Checking the Create Previews checkbox creates a preview of the document 
that is displayed in the Open dialog box.
Checking the Create Thumbnail Icons checkbox creates miniature views of 
the document for the icon views in the Finder.
The Temporary Files area specifies the volume where Color It! stores the 
temporary files it needs to maintain Undo capability. The default location is 
the Virtual Images folder inside Color It! Stuff folder.



Clicking the Add button brings up an Open dialog box to choose additional 
storage areas. The Selected button chooses the highlighted folder. The 
Current button chooses the folder currently open. The New… button creates 
a new folder you can name and locate.

Tools… Preferences
Antialiasing eliminates the jagged edges of text or colored objects. These 
buttons let you select the amount of antialiasing used. 
In most cases, the difference between Good and Best is virtually 
indistinguishable.
Paint Dither:    Sets the palette for dither patterns. Fine uses 33 patterns; 
Medium uses 17; Coarse uses 9. 
Drag Updates:    Controls how images are displayed when moved with the 
mouse. With Outline Only the mouse button must be released before the 
screen updates. With Brief Delay the screen updates after a slight pause and 
before the mouse button is released. With Long Delay the screen updates 
after a longer pause and before the mouse button is released.
Checking the Allow Editing of Tool Positions allows repositioning of the tools 
within the Tool palette. See Chapter 2, The Tools Palette for more information.

Rulers… Preferences
Color It! offers many options to customize the rulers.
The Units pop-up menu lets you select ruler measurements in pixels, inches, 
centimeters, picas or points.
Major Divisions appear in the rulers as a full-height vertical tick mark 
followed by a number. The pop-up menu has several selected increments, or 
others can be entered in the text box.
Minor Divisions are shorter vertical tick marks between the major divisions. 
The pop-up menu has several selected increments, or others can be entered 
in the text box.
As changes are made, the ruler at the bottom of the dialog automatically 
updates to reflect the current values.

Separation… Preferences
The Separation… command opens the Separations Settings dialog box.
The Black Generation area offers two methods: UCR (Undercolor Removal) or 
GCR 
(Grey Component Replacement).
UCR is a technique that replaces some of the cyan, magenta and yellow 
components of the neutral gray and dark shadow areas with black. This helps
compensate for some of the trapping and related problems that occur in 
multicolor printing.
Extreme UCR is not practical. If too much of the three-color gray component 
is removed, detail and density will be lost.
By reducing three colors (cyan, magenta and yellow) and increasing one 
color (black), UCR reduces total ink coverage significantly.



GCR replaces gray components in the colored areas of a reproduction with 
black. The least prominent color is reduced or removed completely along 
with proportional amounts of the other two colors to define a gray 
component which is replaced with black ink.
Total Coverage Limit can be set from 200% to 400%.
Black Ink Limit can be set from 0% to 200%.
Black Starts At can be set from 0% to 90%.
GCR Black Generation can be set from 0 to 90.
Clicking on the Transfer… button opens the Transfer Curves dialog box.
The Transfer Curves dialog is where compensation can be made for dot gain. 
They also enable the user to set the points for the darkest printable shadow 
and the lightest printable highlight.
The points on the curve represent the shadow, quartertone, midtone, three-
quartertone, and highlight. The points can be adjusting by clicking and 
dragging. A curve that slopes above a 45° straight line makes the tones 
darker; curving below the 45° line makes the tones lighter. Shift-clicking will 
move the same dot in all four ink colors at the same time.
Clicking on the Inks… button in the Separations Settings dialog opens the Ink
Calibration dialog box.
The Hue and Grayness area should remain untouched. Densitometer 
readings should be taken for each of the percentages listed. Numbers can be
entered in the Gray Balance textboxes to adjust for color shifts. The numbers
should be adjusted to produce a neutral gray from the three process colors.
Clicking on the Components… button opens the Ink Components Bias dialog 
box. Numbers can be entered in the textboxes for Gray and Color 1/4 Tone, 
Mid Tone and 3/4 Tone to adjust for impurities in the process inks.


